use strict;
my $str = 'example.com/img/fe5afe0482195afff9390692a6cc23e1';
my $regex = qr@/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$@p;
my $subst = '/content/img/$1/$1$2';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";