import Foundation
let pattern = #"/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"example.com/img/fe5afe0482195afff9390692a6cc23e1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/content/img/$1/$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)