# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$"
test_str = "example.com/img/fe5afe0482195afff9390692a6cc23e1"
subst = "/content/img/$1/$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.