// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$").unwrap();
let string = "example.com/img/fe5afe0482195afff9390692a6cc23e1";
let substitution = "/content/img/$1/$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}