# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<TAG>(.*?)<\\/TAG>/<TAG>XXXXX<\/TAG>/gm;t' <<< "<TAG>some content here</TAG>"