const regex = /<TAG>(.*?)<\/TAG>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<TAG>(.*?)<\\\/TAG>', 'gm')
const str = `<TAG>some content here</TAG>`;
const subst = `<TAG>XXXXX</TAG>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);