import re
regex = re.compile(r"<TAG>(.*?)<\/TAG>", flags=re.MULTILINE)
test_str = "<TAG>some content here</TAG>"
subst = "<TAG>XXXXX</TAG>"
result = regex.sub(subst, test_str)
if result:
print(result)