// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<TAG>(.*?)<\/TAG>").unwrap();
let string = "<TAG>some content here</TAG>";
let substitution = "<TAG>XXXXX</TAG>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}