using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<TAG>(.*?)<\/TAG>";
string substitution = @"<TAG>XXXXX</TAG>";
string input = @"<TAG>some content here</TAG>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}