#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<TAG>(.*?)<\/TAG>"
Local $sString = "<TAG>some content here</TAG>"
Local $sSubst = "<TAG>XXXXX</TAG>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)