re = /<TAG>(.*?)<\/TAG>/m
str = '<TAG>some content here</TAG>'
subst = '<TAG>XXXXX</TAG>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result