# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(".*?"|(?<!\\)'.*?(?<!\\)')(*SKIP)(*FAIL)|\?/plant/sg;t' <<< "This is my test ?
I \"stole \"\"?\"\" it from s/o\"
I \"stole ? it from s/o\"
I \"stole '?' it from s/o\"
I 'stole \"?\" it from s/o'
\"?\" look like it works pretty well ?
'this is a question mark - ?'
'this is a double-quoted question mark - \"?\"' ?
'this is a single-quoted question mark - \'?\'' ?
'this is a ? badger\'s question mark ? where is the monkey\'s\'' ?"