# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\".*?\"|(?<!\\)'.*?(?<!\\)')(*SKIP)(*FAIL)|\?"
test_str = ("This is my test ?\n"
"I \"stole \"\"?\"\" it from s/o\"\n"
"I \"stole ? it from s/o\"\n"
"I \"stole '?' it from s/o\"\n"
"I 'stole \"?\" it from s/o'\n"
"\"?\" look like it works pretty well ?\n"
"'this is a question mark - ?'\n"
"'this is a double-quoted question mark - \"?\"' ?\n"
"'this is a single-quoted question mark - \\'?\\'' ?\n"
"'this is a ? badger\\'s question mark ? where is the monkey\\'s\\'' ?")
subst = "plant"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.