$re = '~(".*?"|(?<!\\\\)\'.*?(?<!\\\\)\')(*SKIP)(*FAIL)|\?~s';
$str = 'This is my test ?
I "stole ""?"" it from s/o"
I "stole ? it from s/o"
I "stole \'?\' it from s/o"
I \'stole "?" it from s/o\'
"?" look like it works pretty well ?
\'this is a question mark - ?\'
\'this is a double-quoted question mark - "?"\' ?
\'this is a single-quoted question mark - \\\'?\\\'\' ?
\'this is a ? badger\\\'s question mark ? where is the monkey\\\'s\\\'\' ?';
$subst = "plant";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;