#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(".*?"|(?<!\\)'.*?(?<!\\)')(*SKIP)(*FAIL)|\?"
Local $sString = "This is my test ?" & @CRLF & _
"I "stole ""?"" it from s/o"" & @CRLF & _
"I "stole ? it from s/o"" & @CRLF & _
"I "stole '?' it from s/o"" & @CRLF & _
"I 'stole "?" it from s/o'" & @CRLF & _
""?" look like it works pretty well ?" & @CRLF & _
"'this is a question mark - ?'" & @CRLF & _
"'this is a double-quoted question mark - "?"' ?" & @CRLF & _
"'this is a single-quoted question mark - \'?\'' ?" & @CRLF & _
"'this is a ? badger\'s question mark ? where is the monkey\'s\'' ?"
Local $sSubst = "plant"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)