using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*?""|(?<!\\)'.*?(?<!\\)')(*SKIP)(*FAIL)|\?";
string substitution = @"plant";
string input = @"This is my test ?
I ""stole ""?"" it from s/o""
I ""stole ? it from s/o""
I ""stole '?' it from s/o""
I 'stole ""?"" it from s/o'
""?"" look like it works pretty well ?
'this is a question mark - ?'
'this is a double-quoted question mark - ""?""' ?
'this is a single-quoted question mark - \'?\'' ?
'this is a ? badger\'s question mark ? where is the monkey\'s\'' ?";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}