const regex = new RegExp('(".*?"|(?<!\\\\)\\'.*?(?<!\\\\)\\')(*SKIP)(*FAIL)|\\?', 'sg')
const str = `This is my test ?
I "stole ""?"" it from s/o"
I "stole ? it from s/o"
I "stole '?' it from s/o"
I 'stole "?" it from s/o'
"?" look like it works pretty well ?
'this is a question mark - ?'
'this is a double-quoted question mark - "?"' ?
'this is a single-quoted question mark - \\'?\\'' ?
'this is a ? badger\\'s question mark ? where is the monkey\\'s\\'' ?`;
const subst = `plant`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);