#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b\d+\b).*\1"
Local $sString = "#3#6796#" & @CRLF & _
"#8226#16#" & @CRLF & _
"#8227#16#" & @CRLF & _
"#8256#8033#" & @CRLF & _
"#8254#8256#8033#" & @CRLF & _
"#8270#8256#8033#" & @CRLF & _
"#8272#8256#8033#" & @CRLF & _
"#8242#8081#" & @CRLF & _
"#8241#8242#8081#" & @CRLF & _
"#8243#8242#8081#" & @CRLF & _
"#8254#8242#8081#" & @CRLF & _
"#8265#8242#8081#" & @CRLF & _
"#8241#8241#8081#" & @CRLF & _
"#8243#8242#8243#" & @CRLF & _
"#8254#8242#8254#" & @CRLF & _
"#8081#8242#8081#" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")