import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\d+\\b).*\\1";
final String string = "#3#6796#\n"
+ "#8226#16#\n"
+ "#8227#16#\n"
+ "#8256#8033#\n"
+ "#8254#8256#8033#\n"
+ "#8270#8256#8033#\n"
+ "#8272#8256#8033#\n"
+ "#8242#8081#\n"
+ "#8241#8242#8081#\n"
+ "#8243#8242#8081#\n"
+ "#8254#8242#8081#\n"
+ "#8265#8242#8081#\n"
+ "#8241#8241#8081#\n"
+ "#8243#8242#8243#\n"
+ "#8254#8242#8254#\n"
+ "#8081#8242#8081#\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}