const regex = /(\b\d+\b).*\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\d+\\b).*\\1', 'g')
const str = `#3#6796#
#8226#16#
#8227#16#
#8256#8033#
#8254#8256#8033#
#8270#8256#8033#
#8272#8256#8033#
#8242#8081#
#8241#8242#8081#
#8243#8242#8081#
#8254#8242#8081#
#8265#8242#8081#
#8241#8241#8081#
#8243#8242#8243#
#8254#8242#8254#
#8081#8242#8081#
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}