re = /(\b\d+\b).*\1/
str = '#3#6796#
#8226#16#
#8227#16#
#8256#8033#
#8254#8256#8033#
#8270#8256#8033#
#8272#8256#8033#
#8242#8081#
#8241#8242#8081#
#8243#8242#8081#
#8254#8242#8081#
#8265#8242#8081#
#8241#8241#8081#
#8243#8242#8243#
#8254#8242#8254#
#8081#8242#8081#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end