use strict;
my $str = '#3#6796#
#8226#16#
#8227#16#
#8256#8033#
#8254#8256#8033#
#8270#8256#8033#
#8272#8256#8033#
#8242#8081#
#8241#8242#8081#
#8243#8242#8081#
#8254#8242#8081#
#8265#8242#8081#
#8241#8241#8081#
#8243#8242#8243#
#8254#8242#8254#
#8081#8242#8081#
';
my $regex = qr/(\b\d+\b).*\1/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}