import Foundation
let pattern = #"(\b\d+\b).*\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#3#6796#
#8226#16#
#8227#16#
#8256#8033#
#8254#8256#8033#
#8270#8256#8033#
#8272#8256#8033#
#8242#8081#
#8241#8242#8081#
#8243#8242#8081#
#8254#8242#8081#
#8265#8242#8081#
#8241#8241#8081#
#8243#8242#8243#
#8254#8242#8254#
#8081#8242#8081#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)