using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<=^.{50})\r?\n";
string substitution = @"";
string input = @"COMMENT ON COLUMN ""vendor"".""things_andstuf_associa
tions"".""id"" IS 'The unique identifier for a things
andstuf association record.';
COMMENT ON COLUMN ""vendor"".""things_andstuf_associa
tions"".""course_id"" IS 'Identifies the course.';
COMMENT ON COLUMN ""vendor"".""things_andstuf_associa
tions"".""created_at"" IS 'Timestamp of when the reco
rd was created.';";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}