import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=^.{50})\\r?\\n";
final String string = "COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
+ "tions\".\"id\" IS 'The unique identifier for a things\n"
+ "andstuf association record.';\n\n"
+ "COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
+ "tions\".\"course_id\" IS 'Identifies the course.';\n"
+ "COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
+ "tions\".\"created_at\" IS 'Timestamp of when the reco\n"
+ "rd was created.';";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}