#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)"
Local $sString = "::0fff:187.0.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")