import re
regex = re.compile(r"[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)")
test_str = "::0fff:187.0.0.1"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")