re = /[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)/
str = '::0fff:187.0.0.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end