const regex = /[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[:][:][0-9a-f]+[:](\\b\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\b)', '')
const str = `::0fff:187.0.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}