using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)";
string input = @"::0fff:187.0.0.1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}