package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)`)
var str = `::0fff:187.0.0.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}