$re = '/[:][:][0-9a-f]+[:](\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)/';
$str = '::0fff:187.0.0.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);