#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Download here:\s<a\shref=").*?(?=">)"
Local $sString = "Download here: <a href="/images/alex.jpg">AlexPicture</a>" & @CRLF & _
"Download here: <a href="/images/nat.jpg">NAT</a>" & @CRLF & _
"Download here: <a href="/images/dog/pat.jpg">Pat the dog</a>" & @CRLF & _
"Download here: <a href="/images/chuchu.jpg.jpg">ChuChu</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")