re = /(?<=Download here:\s<a\shref=").*?(?=">)/
str = 'Download here: <a href="/images/alex.jpg">AlexPicture</a>
Download here: <a href="/images/nat.jpg">NAT</a>
Download here: <a href="/images/dog/pat.jpg">Pat the dog</a>
Download here: <a href="/images/chuchu.jpg.jpg">ChuChu</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end