import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Download here:\\s<a\\shref=\").*?(?=\">)";
final String string = "Download here: <a href=\"/images/alex.jpg\">AlexPicture</a>\n"
+ "Download here: <a href=\"/images/nat.jpg\">NAT</a>\n"
+ "Download here: <a href=\"/images/dog/pat.jpg\">Pat the dog</a>\n"
+ "Download here: <a href=\"/images/chuchu.jpg.jpg\">ChuChu</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}