const regex = /(?<=Download here:\s<a\shref=").*?(?=">)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Download here:\\s<a\\shref=").*?(?=">)', 'g')
const str = `Download here: <a href="/images/alex.jpg">AlexPicture</a>
Download here: <a href="/images/nat.jpg">NAT</a>
Download here: <a href="/images/dog/pat.jpg">Pat the dog</a>
Download here: <a href="/images/chuchu.jpg.jpg">ChuChu</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}