using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Download here:\s<a\shref="").*?(?="">)";
string input = @"Download here: <a href=""/images/alex.jpg"">AlexPicture</a>
Download here: <a href=""/images/nat.jpg"">NAT</a>
Download here: <a href=""/images/dog/pat.jpg"">Pat the dog</a>
Download here: <a href=""/images/chuchu.jpg.jpg"">ChuChu</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}