use strict;
my $str = 'Download here: <a href="/images/alex.jpg">AlexPicture</a>
Download here: <a href="/images/nat.jpg">NAT</a>
Download here: <a href="/images/dog/pat.jpg">Pat the dog</a>
Download here: <a href="/images/chuchu.jpg.jpg">ChuChu</a>';
my $regex = qr/(?<=Download here:\s<a\shref=").*?(?=">)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}