$re = '/(?<=Download here:\s<a\shref=").*?(?=">)/';
$str = 'Download here: <a href="/images/alex.jpg">AlexPicture</a>
Download here: <a href="/images/nat.jpg">NAT</a>
Download here: <a href="/images/dog/pat.jpg">Pat the dog</a>
Download here: <a href="/images/chuchu.jpg.jpg">ChuChu</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);