#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$"
Local $sString = "2-2,1" & @CRLF & _
"1-5,5,15-29" & @CRLF & _
"1-1-1-1" & @CRLF & _
"2,5,7-20" & @CRLF & _
"2,3-6,3" & @CRLF & _
"1-24,5-6,2-9" & @CRLF & _
"15,25,3" & @CRLF & _
"412,28,1-31,15" & @CRLF & _
"1-5,5,15-32" & @CRLF & _
"1-5,5,45-31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")