import re
regex = re.compile(r"^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$", flags=re.MULTILINE)
test_str = ("2-2,1\n"
"1-5,5,15-29\n"
"1-1-1-1\n"
"2,5,7-20\n"
"2,3-6,3\n"
"1-24,5-6,2-9\n"
"15,25,3\n"
"412,28,1-31,15\n"
"1-5,5,15-32\n"
"1-5,5,45-31")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")