const regex = /^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'int\'[1-2]?[1-9]|3[01])((,\\g\'int\')|(-\\g\'int\'(?=$|,)))*$', 'gm')
const str = `2-2,1
1-5,5,15-29
1-1-1-1
2,5,7-20
2,3-6,3
1-24,5-6,2-9
15,25,3
412,28,1-31,15
1-5,5,15-32
1-5,5,45-31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}