use strict;
my $str = '2-2,1
1-5,5,15-29
1-1-1-1
2,5,7-20
2,3-6,3
1-24,5-6,2-9
15,25,3
412,28,1-31,15
1-5,5,15-32
1-5,5,45-31';
my $regex = qr/^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}