re = /^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$/m
str = '2-2,1
1-5,5,15-29
1-1-1-1
2,5,7-20
2,3-6,3
1-24,5-6,2-9
15,25,3
412,28,1-31,15
1-5,5,15-32
1-5,5,45-31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end