# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/binary_function\(\[([^][\s,]+),([^][\s,]+)]\)/\U$1$2\E/gm;t' <<< "binary_function([x,y])
binary_function([x1,y1])"