import Foundation
let pattern = #"binary_function\(\[([^][\s,]+),([^][\s,]+)]\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
binary_function([x,y])
binary_function([x1,y1])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1$2\E"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)