package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)binary_function\(\[([^][\s,]+),([^][\s,]+)]\)`)
var str = `binary_function([x,y])
binary_function([x1,y1])`
var substitution = "\U$1$2\E"
fmt.Println(re.ReplaceAllString(str, substitution))
}