use strict;
my $str = 'binary_function([x,y])
binary_function([x1,y1])';
my $regex = qr/binary_function\(\[([^][\s,]+),([^][\s,]+)]\)/mp;
my $subst = '\\U$1$2\\E';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";