using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"binary_function\(\[([^][\s,]+),([^][\s,]+)]\)";
string substitution = @"\U$1$2\E";
string input = @"binary_function([x,y])
binary_function([x1,y1])";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}