import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "binary_function\\(\\[([^][\\s,]+),([^][\\s,]+)]\\)";
final String string = "binary_function([x,y])\n"
+ "binary_function([x1,y1])";
final String subst = "\\U$1$2\\E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}